Patch to release inf image for Bronze release
[pti/rtp.git] / meta-oran / recipes-containers / kubernetes-plugins / kubernetes-dashboard_1.8.3.bb
index 6cf7211..370c997 100644 (file)
@@ -1,6 +1,17 @@
 #
 # Copyright (C) 2019 Wind River Systems, Inc.
 #
+#  Licensed under the Apache License, Version 2.0 (the "License");
+#  you may not use this file except in compliance with the License.
+#  You may obtain a copy of the License at
+#
+#      http://www.apache.org/licenses/LICENSE-2.0
+#
+#  Unless required by applicable law or agreed to in writing, software
+#  distributed under the License is distributed on an "AS IS" BASIS,
+#  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+#  See the License for the specific language governing permissions and
+#  limitations under the License.
 
 SUMMARY = "General-purpose web UI for Kubernetes clusters"
 DESCRIPTION = "\
@@ -16,7 +27,6 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=b1e01b26bacfc2232046c90a330332b3"
 
 SRC_URI = "\
     https://github.com/kubernetes/dashboard/archive/v${PV}.tar.gz;downloadfilename=${BPN}-v${PV}.tar.gz \
-    file://docker-img-kubernetes-dashboard-v1.8.3.tar.bz2;unpack=0 \
     file://kubernetes-dashboard-admin.rbac.yaml \
     file://kubernetes-dashboard.yaml-set-the-NodePort-type.patch \
 "
@@ -26,9 +36,6 @@ SRC_URI[sha256sum] = "9096f86d4107a6d23f2cff5edd1acae2faf25719a343c319860fd6a740
 
 S = "${WORKDIR}/dashboard-${PV}"
 
-PACKAGES =+ "${PN}-img"
-
-DOCKER_IMG = "/opt/docker_images/${BPN}"
 K8S_PLUGINS = "${sysconfdir}/kubernetes/plugins/${BPN}"
 
 do_install() {
@@ -36,10 +43,4 @@ do_install() {
     install -m 644 ${WORKDIR}/kubernetes-dashboard-admin.rbac.yaml ${D}${K8S_PLUGINS}
     install -m 644 ${S}/src/deploy/recommended/kubernetes-dashboard.yaml ${D}${K8S_PLUGINS}
     install -m 644 ${S}/README.md ${D}${K8S_PLUGINS}
-
-    # Install the saved docker image
-    install -d ${D}${DOCKER_IMG}
-    install -m 644 ${WORKDIR}/docker-img-*.tar.bz2 ${D}${DOCKER_IMG}
 }
-
-FILES_${PN}-img = "${DOCKER_IMG}"