stx-metal: add setting for debain style networking in kickstart files
[pti/rtp.git] / meta-oran / recipes-containers / kubernetes-plugins / cpu-manager-for-kubernetes_1.3.1.bb
index 58b30bd..c534c73 100644 (file)
@@ -1,6 +1,17 @@
 #
 # Copyright (C) 2019 Wind River Systems, Inc.
 #
+#  Licensed under the Apache License, Version 2.0 (the "License");
+#  you may not use this file except in compliance with the License.
+#  You may obtain a copy of the License at
+#
+#      http://www.apache.org/licenses/LICENSE-2.0
+#
+#  Unless required by applicable law or agreed to in writing, software
+#  distributed under the License is distributed on an "AS IS" BASIS,
+#  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+#  See the License for the specific language governing permissions and
+#  limitations under the License.
 
 SUMMARY = "CPU Manager for Kubernetes"
 uDESCRIPTION = "\
@@ -17,7 +28,6 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=d62f25248fea71c71fb2b520c72b5171"
 
 SRC_URI = "\
     https://github.com/intel/${BPN}/archive/v${PV}.tar.gz;downloadfilename=${BPN}-v${PV}.tar.gz \
-    file://docker-img-cmk-v1.3.1.tar.bz2;unpack=0 \
     file://cmk-requirements.txt-add-urllib3-1.24.patch \
     file://cmk-cluster-init-pod-template.yaml \
 "
@@ -27,9 +37,6 @@ SRC_URI[sha256sum] = "e86feb81751c6715247577c47070beca273022b470ae09c856e6da72f1
 
 S = "${WORKDIR}/CPU-Manager-for-Kubernetes-${PV}"
 
-PACKAGES =+ "${PN}-img"
-
-DOCKER_IMG = "/opt/docker_images/${BPN}"
 K8S_PLUGINS_SRC = "/opt/kubernetes_plugins/${BPN}"
 K8S_PLUGINS = "${sysconfdir}/kubernetes/plugins/${BPN}"
 
@@ -48,20 +55,14 @@ do_install() {
     install -m 644 ${S}/resources/authorization/cmk-rbac-rules.yaml ${D}${K8S_PLUGINS}
     install -m 644 ${WORKDIR}/cmk-cluster-init-pod-template.yaml ${D}${K8S_PLUGINS}
 
-    # Install the saved docker image
-    install -d ${D}${DOCKER_IMG}
-    install -m 644 ${WORKDIR}/docker-img-*.tar.bz2 ${D}${DOCKER_IMG}
-
     # Install all the src
     install -d ${D}${K8S_PLUGINS_SRC}
     cp -a --no-preserve=ownership ${S}/* ${D}${K8S_PLUGINS_SRC}
 }
 
 FILES_${PN} += "${K8S_PLUGINS_SRC}"
-FILES_${PN}-img = "${DOCKER_IMG}"
 
 # provides a short alias
 RPROVIDES_${PN} = "cmk"
-RPROVIDES_${PN}-img = "cmk-img"
 
 INSANE_SKIP_${PN} = "file-rdeps"