oran-shell-release.yaml: release image for E
[pti/rtp.git] / meta-oran / recipes-containers / kubernetes / kubernetes_1.15.2.bb
index 24e3537..462b048 100644 (file)
@@ -1,6 +1,17 @@
 #
 # Copyright (C) 2019 Wind River Systems, Inc.
 #
+#  Licensed under the Apache License, Version 2.0 (the "License");
+#  you may not use this file except in compliance with the License.
+#  You may obtain a copy of the License at
+#
+#      http://www.apache.org/licenses/LICENSE-2.0
+#
+#  Unless required by applicable law or agreed to in writing, software
+#  distributed under the License is distributed on an "AS IS" BASIS,
+#  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+#  See the License for the specific language governing permissions and
+#  limitations under the License.
 
 require kubernetes.inc
 
@@ -8,4 +19,14 @@ PV = "1.15.2+git${SRCREV_kubernetes}"
 SRCREV_kubernetes = "f6278300bebbb750328ac16ee6dd3aa7d3549568"
 SRC_BRANCH = "release-1.15"
 
-inherit ${@bb.utils.contains('GOVERSION', '1.2.%', 'go112', '', d)}
+SRC_URI += "\
+    file://k8s.conf \
+"
+
+inherit go112
+
+do_install_append() {
+    # Install the sysctl config for k8s
+    install -d ${D}${sysconfdir}/sysctl.d/
+    install -m 644 -D ${WORKDIR}/k8s.conf ${D}${sysconfdir}/sysctl.d/
+}