stx-ha: add missing dependency in Makefile for libsm_watchdog_nfs
[pti/rtp.git] / meta-oran / recipes-containers / kubernetes / kubernetes_1.15.2.bb
index c2d8438..462b048 100644 (file)
@@ -1,6 +1,17 @@
 #
 # Copyright (C) 2019 Wind River Systems, Inc.
 #
+#  Licensed under the Apache License, Version 2.0 (the "License");
+#  you may not use this file except in compliance with the License.
+#  You may obtain a copy of the License at
+#
+#      http://www.apache.org/licenses/LICENSE-2.0
+#
+#  Unless required by applicable law or agreed to in writing, software
+#  distributed under the License is distributed on an "AS IS" BASIS,
+#  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+#  See the License for the specific language governing permissions and
+#  limitations under the License.
 
 require kubernetes.inc
 
@@ -8,33 +19,14 @@ PV = "1.15.2+git${SRCREV_kubernetes}"
 SRCREV_kubernetes = "f6278300bebbb750328ac16ee6dd3aa7d3549568"
 SRC_BRANCH = "release-1.15"
 
-# The docker images included in docker-img-kubernetes-v1.15.2.tar.bz2:
-# k8s.gcr.io/kube-scheduler                             v1.15.2               88fa9cb27bd2        2 months ago        81.1MB
-# k8s.gcr.io/kube-proxy                                 v1.15.2               167bbf6c9338        2 months ago        82.4MB
-# k8s.gcr.io/kube-controller-manager                    v1.15.2               9f5df470155d        2 months ago        159MB
-# k8s.gcr.io/kube-apiserver                             v1.15.2               34a53be6c9a7        2 months ago        207MB
-# k8s.gcr.io/coredns                                    1.3.1                 eb516548c180        9 months ago        40.3MB
-# k8s.gcr.io/etcd                                       3.3.10                2c4adeb21b4f        10 months ago       258MB
-
 SRC_URI += "\
     file://k8s.conf \
-    file://docker-img-kubernetes-v1.15.2.tar.bz2;unpack=0 \
 "
 
 inherit go112
 
-PACKAGES =+ "${PN}-img"
-
-DOCKER_IMG = "/opt/docker_images/${BPN}"
-
 do_install_append() {
-    # Install the saved docker image
-    install -d ${D}${DOCKER_IMG}
-    install -m 644 ${WORKDIR}/docker-img-*.tar.bz2 ${D}${DOCKER_IMG}
-
     # Install the sysctl config for k8s
     install -d ${D}${sysconfdir}/sysctl.d/
     install -m 644 -D ${WORKDIR}/k8s.conf ${D}${sysconfdir}/sysctl.d/
 }
-
-FILES_${PN}-img = "${DOCKER_IMG}"