stx-metal: add kickstart fixes for poky-stx
[pti/rtp.git] / meta-oran / recipes-containers / docker / docker_%.bbappend
index 78364e8..b1f0d42 100644 (file)
@@ -1,8 +1,21 @@
+#
+# Copyright (C) 2019 Wind River Systems, Inc.
+#
+#  Licensed under the Apache License, Version 2.0 (the "License");
+#  you may not use this file except in compliance with the License.
+#  You may obtain a copy of the License at
+#
+#      http://www.apache.org/licenses/LICENSE-2.0
+#
+#  Unless required by applicable law or agreed to in writing, software
+#  distributed under the License is distributed on an "AS IS" BASIS,
+#  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+#  See the License for the specific language governing permissions and
+#  limitations under the License.
+
 FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:"
 
-do_compile_prepend() {
-    unset GOCACHE
-}
+inherit go112
 
 do_install_append() {
     sed -i '/ExecStart=/a ExecStartPost=/usr/sbin/iptables -P FORWARD ACCEPT' ${D}${systemd_unitdir}/system/docker.service