barbican: fix path issue in service unitfile and missing dir
[pti/rtp.git] / meta-oran / recipes-base / packagegroups / packagegroup-oran.bb
index 2803428..e967b13 100644 (file)
@@ -1,12 +1,22 @@
 #
 # Copyright (C) 2019 Wind River Systems, Inc.
 #
+#  Licensed under the Apache License, Version 2.0 (the "License");
+#  you may not use this file except in compliance with the License.
+#  You may obtain a copy of the License at
+#
+#      http://www.apache.org/licenses/LICENSE-2.0
+#
+#  Unless required by applicable law or agreed to in writing, software
+#  distributed under the License is distributed on an "AS IS" BASIS,
+#  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+#  See the License for the specific language governing permissions and
+#  limitations under the License.
 
 DESCRIPTION = "Packagegroup for ORAN packages"
 
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302 \
-                    file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
 
 PACKAGE_ARCH = "${MACHINE_ARCH}"
 
@@ -16,6 +26,7 @@ PROVIDES = "${PACKAGES}"
 PACKAGES += " \
     ${PN}-base \
     ${PN}-docker \
+    ${PN}-kernel \
     ${PN}-k8s \
     ${PN}-vm \
     ${PN}-trace-tools \
@@ -26,6 +37,7 @@ PACKAGES += " \
 RDEPENDS_${PN} = "\
     ${PN}-base \
     ${PN}-docker \
+    ${PN}-kernel \
     ${PN}-k8s \
     ${PN}-vm \
     ${PN}-trace-tools \
@@ -39,6 +51,11 @@ RDEPENDS_${PN}-base = "\
     tunctl \
     udev \
     udev-extraconf \
+    turbostat \
+    cpupower \
+    cpufrequtils \
+    msr-tools \
+    htop \
 "
 
 RDEPENDS_${PN}-docker = "\
@@ -46,22 +63,21 @@ RDEPENDS_${PN}-docker = "\
     docker-registry \
 "
 
+RDEPENDS_${PN}-kernel = "\
+    kernel-base \
+    kernel-dev \
+    kernel-devsrc \
+    kernel-modules \
+    kernel-vmlinux \
+"
 RDEPENDS_${PN}-k8s = "\
     cni \
     flannel \
     iproute2-tc \
     kubernetes \
     kubernetes-dashboard \
+    node-feature-discovery \
     multus-cni \
-    cmk \
-"
-
-RRECOMMENDS_${PN}-k8s = "\
-    flannel-img \
-    kubernetes-img \
-    kubernetes-dashboard-img \
-    multus-cni-img \
-    cmk-img \
 "
 
 RDEPENDS_${PN}-vm = "\