docs/release-notes.rst: fix the version date
[pti/rtp.git] / meta-oran / recipes-base / packagegroups / packagegroup-oran.bb
index 4114b8d..550a3dc 100644 (file)
@@ -1,36 +1,48 @@
 #
 # Copyright (C) 2019 Wind River Systems, Inc.
 #
+#  Licensed under the Apache License, Version 2.0 (the "License");
+#  you may not use this file except in compliance with the License.
+#  You may obtain a copy of the License at
+#
+#      http://www.apache.org/licenses/LICENSE-2.0
+#
+#  Unless required by applicable law or agreed to in writing, software
+#  distributed under the License is distributed on an "AS IS" BASIS,
+#  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+#  See the License for the specific language governing permissions and
+#  limitations under the License.
 
 DESCRIPTION = "Packagegroup for ORAN packages"
 
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302 \
-                    file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
 
 PACKAGE_ARCH = "${MACHINE_ARCH}"
 
 inherit packagegroup
 
 PROVIDES = "${PACKAGES}"
-PACKAGES = " \
+PACKAGES += " \
     ${PN}-base \
     ${PN}-docker \
+    ${PN}-kernel \
     ${PN}-k8s \
     ${PN}-vm \
-    ${PN}-criu \
     ${PN}-trace-tools \
     ${PN}-lttng-toolchain \
+    ${PN}-glusterfs \
 "
 
 RDEPENDS_${PN} = "\
     ${PN}-base \
     ${PN}-docker \
+    ${PN}-kernel \
     ${PN}-k8s \
     ${PN}-vm \
-    ${PN}-criu \
     ${PN}-trace-tools \
     ${PN}-lttng-toolchain \
+    ${PN}-glusterfs \
 "
 
 RDEPENDS_${PN}-base = "\
@@ -39,6 +51,19 @@ RDEPENDS_${PN}-base = "\
     tunctl \
     udev \
     udev-extraconf \
+    cpupower \
+    cpufrequtils \
+    htop \
+"
+
+RDEPENDS_${PN}-base_append_x86 = "\
+    turbostat \
+    msr-tools \
+"
+
+RDEPENDS_${PN}-base_append_x86-64 = "\
+    turbostat \
+    msr-tools \
 "
 
 RDEPENDS_${PN}-docker = "\
@@ -46,10 +71,21 @@ RDEPENDS_${PN}-docker = "\
     docker-registry \
 "
 
+RDEPENDS_${PN}-kernel = "\
+    kernel-base \
+    kernel-dev \
+    kernel-devsrc \
+    kernel-modules \
+    kernel-vmlinux \
+"
 RDEPENDS_${PN}-k8s = "\
     cni \
+    flannel \
     iproute2-tc \
     kubernetes \
+    kubernetes-dashboard \
+    node-feature-discovery \
+    multus-cni \
 "
 
 RDEPENDS_${PN}-vm = "\
@@ -66,18 +102,27 @@ RRECOMMENDS_${PN}-vm = "\
     kernel-module-kvm-amd \
 "
 
-RDEPENDS_${PN}-criu = "\
-    criu \
-    protobuf-c \
-"
-
 RDEPENDS_${PN}-trace-tools = "\
-    diod \
     socat \
 "
+# It's blacklisted becasue of build failure
+#    diod
 
-RDEPENDS_${PN}-trace-tools = "\
+RDEPENDS_${PN}-lttng-toolchain = "\
     babeltrace \
     lttng-tools \
     lttng-ust \
 "
+
+RDEPENDS_${PN}-glusterfs = "\
+    fuse \
+    fuse-utils \
+    libulockmgr \
+    glusterfs \
+    glusterfs-rdma \
+    glusterfs-geo-replication \
+    glusterfs-fuse \
+    glusterfs-server \
+    xfsdump \
+    xfsprogs \
+"