mtce.inc: fix typos for services.d directory
[pti/rtp.git] / meta-oran / recipes-base / images / oran-image-inf-host.bb
index 5160882..5fee605 100644 (file)
@@ -1,42 +1,44 @@
 #
 # Copyright (C) 2019 Wind River Systems, Inc.
 #
-DESCRIPTION = "An image suitable for a O-RAN INF host."
+#  Licensed under the Apache License, Version 2.0 (the "License");
+#  you may not use this file except in compliance with the License.
+#  You may obtain a copy of the License at
+#
+#      http://www.apache.org/licenses/LICENSE-2.0
+#
+#  Unless required by applicable law or agreed to in writing, software
+#  distributed under the License is distributed on an "AS IS" BASIS,
+#  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+#  See the License for the specific language governing permissions and
+#  limitations under the License.
 
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302 \
-                    file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+DESCRIPTION = "An image suitable for a O-RAN INF host."
 
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
 
 require recipes-base/images/oran-image-inf-minimal.bb
 
-IMAGE_INSTALL += " \
-    kernel-modules \
-    packagegroup-base-extended \
-    packagegroup-wr-base \
-    packagegroup-wr-base-net \
-    packagegroup-wr-boot \
-"
-
 IMAGE_INSTALL += " \
     aufs-util \
     celt051 \
-    ceph \
     dpdk \
     hwloc \
+    kernel-modules \
     openvswitch \
-    packagegroup-containers \
-    packagegroup-glusterfs \
-    packagegroup-oran-criu \
-    packagegroup-oran-debug \
-    packagegroup-oran-default-monitoring \
-    packagegroup-oran-docker \
-    packagegroup-oran-lttng-toolchain \
+    packagegroup-base-extended \
+    packagegroup-oran \
+    packagegroup-wr-base \
+    packagegroup-wr-base-net \
     python-pyparsing \
     rt-tests \
     schedtool-dl \
+"
+
+IMAGE_INSTALL_append_x86-64 = " \
+    ceph \
     spice \
-    system-report \
 "
 
 IMAGE_FEATURES += " \