stx-anaconda-image.bbclass: add error handling when copy pkgs
[pti/rtp.git] / meta-oran / recipes-base / images / oran-image-inf-host.bb
index de8e565..5fee605 100644 (file)
@@ -1,6 +1,18 @@
 #
 # Copyright (C) 2019 Wind River Systems, Inc.
 #
+#  Licensed under the Apache License, Version 2.0 (the "License");
+#  you may not use this file except in compliance with the License.
+#  You may obtain a copy of the License at
+#
+#      http://www.apache.org/licenses/LICENSE-2.0
+#
+#  Unless required by applicable law or agreed to in writing, software
+#  distributed under the License is distributed on an "AS IS" BASIS,
+#  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+#  See the License for the specific language governing permissions and
+#  limitations under the License.
+
 DESCRIPTION = "An image suitable for a O-RAN INF host."
 
 LICENSE = "Apache-2.0"
@@ -11,7 +23,6 @@ require recipes-base/images/oran-image-inf-minimal.bb
 IMAGE_INSTALL += " \
     aufs-util \
     celt051 \
-    ceph \
     dpdk \
     hwloc \
     kernel-modules \
@@ -23,6 +34,10 @@ IMAGE_INSTALL += " \
     python-pyparsing \
     rt-tests \
     schedtool-dl \
+"
+
+IMAGE_INSTALL_append_x86-64 = " \
+    ceph \
     spice \
 "