image: re-org the image and distro
[pti/rtp.git] / meta-oran / recipes-base / images / oran-image-inf-guest.bb
@@ -1,33 +1,28 @@
 #
 # Copyright (C) 2019 Wind River Systems, Inc.
 #
-DESCRIPTION = "An image suitable for a O-RAN guest."
+DESCRIPTION = "An image suitable for a O-RAN INF guest."
 
 LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302 \
                     file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
 
 
-require recipes-base/images/wrlinux-image-oran-minimal.bb
+require recipes-base/images/oran-image-inf-minimal.bb
 
-# OVP specific packages
 IMAGE_INSTALL += " \
-    packagegroup-ovp-trace-tools \
-    hwloc \
-    system-report \
     acpid-default-scripts \
-"
-
-IMAGE_INSTALL_append_qemux86-64 = " dpdk"
-
-IMAGE_INSTALL += " \
+    hwloc \
     kernel-modules \
     packagegroup-base-extended \
-    packagegroup-wr-base \
     packagegroup-containers \
+    packagegroup-oran-trace-tools \
+    packagegroup-wr-base \
     packagegroup-wr-base-net \
     packagegroup-wr-boot \
-    "
+    system-report \
+"
+IMAGE_INSTALL_append_qemux86-64 = " dpdk"
 
 IMAGE_FEATURES += " \
     nfs-server \
@@ -40,6 +35,6 @@ IMAGE_FEATURES += " \
     wr-core-sys-util \
     wr-core-util \
     wr-core-mail \
-    "
+"
 
 COMPATIBLE_MACHINE = "qemux86|qemux86-64"