image: re-org the image and distro
[pti/rtp.git] / meta-oran / recipes-base / images / oran-image-inf-guest.bb
diff --git a/meta-oran/recipes-base/images/oran-image-inf-guest.bb b/meta-oran/recipes-base/images/oran-image-inf-guest.bb
new file mode 100644 (file)
index 0000000..247e2e3
--- /dev/null
@@ -0,0 +1,40 @@
+#
+# Copyright (C) 2019 Wind River Systems, Inc.
+#
+DESCRIPTION = "An image suitable for a O-RAN INF guest."
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302 \
+                    file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+
+require recipes-base/images/oran-image-inf-minimal.bb
+
+IMAGE_INSTALL += " \
+    acpid-default-scripts \
+    hwloc \
+    kernel-modules \
+    packagegroup-base-extended \
+    packagegroup-containers \
+    packagegroup-oran-trace-tools \
+    packagegroup-wr-base \
+    packagegroup-wr-base-net \
+    packagegroup-wr-boot \
+    system-report \
+"
+IMAGE_INSTALL_append_qemux86-64 = " dpdk"
+
+IMAGE_FEATURES += " \
+    nfs-server \
+    package-management \
+    wr-core-db \
+    wr-core-interactive \
+    wr-core-net \
+    wr-core-perl \
+    wr-core-python \
+    wr-core-sys-util \
+    wr-core-util \
+    wr-core-mail \
+"
+
+COMPATIBLE_MACHINE = "qemux86|qemux86-64"