2 ## Copyright (C) 2019 Wind River Systems, Inc.
4 # Licensed under the Apache License, Version 2.0 (the "License");
5 # you may not use this file except in compliance with the License.
6 # You may obtain a copy of the License at
8 # http://www.apache.org/licenses/LICENSE-2.0
10 # Unless required by applicable law or agreed to in writing, software
11 # distributed under the License is distributed on an "AS IS" BASIS,
12 # WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 # See the License for the specific language governing permissions and
14 # limitations under the License.
16 python __anonymous() {
17 if bb.utils.contains('DEPENDS', 'openssl', True, False, d) or \
18 bb.utils.contains('DEPENDS', 'openssl-native', True, False, d):
19 d.setVar('DEPENDS', d.getVar('DEPENDS').replace('openssl', 'openssl10'))
20 d.setVar('DEPENDS', d.getVar('DEPENDS').replace('openssl-native', 'openssl10-native'))
24 python do_ssl10_mk_symlink() {
27 l = d.getVar("STAGING_INCDIR") + "/openssl"
31 elif os.path.isdir(l):
34 os.symlink("openssl10/openssl",l)
36 l = d.getVar("STAGING_LIBDIR")
37 if os.path.islink(l + "/libssl.so"):
38 os.unlink(l + "/libssl.so")
39 os.unlink(l + "/libcrypto.so")
41 os.symlink("libssl.so.1.0.2", l + "/libssl.so")
42 os.symlink("libcrypto.so.1.0.2", l + "/libcrypto.so")
45 addtask ssl10_mk_symlink before do_configure after do_prepare_recipe_sysroot