53b5a08a7c45b6bb47bc94013dfd0149edeb9567
[pti/rtp.git] / meta-stx-oran / recipes-core / base-files / base-files_%.bbappend
1 #
2 ## Copyright (C) 2021 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 SUBPATH1 = "centos-release-config"
17 DSTSUFX1 = "stx-release-config"
18
19 SRC_URI += " \
20         git://opendev.org/starlingx/config-files.git;protocol=https;destsuffix=${DSTSUFX1};branch="r/stx.3.0";subpath=${SUBPATH1};name=opendev \
21         "
22
23 do_install_append() {
24     install -m 644 ${WORKDIR}/${DSTSUFX1}/files/issue ${D}/${sysconfdir}/issue
25     install -m 644 ${WORKDIR}/${DSTSUFX1}/files/issue.net ${D}/${sysconfdir}/issue.net
26
27     sed -i -e 's/@PLATFORM_RELEASE@/${ORAN_REL}/' ${D}${sysconfdir}/issue*
28 }