Add initial meta-stx to support StarlingX build
[pti/rtp.git] / meta-stx / recipes-support / qpid-proton / qpid-proton_0.28.0.bb
1 #
2 # Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 DESCRIPTION = "Qpid Proton is a high-performance, lightweight messaging library."
17 LICENSE = "Apache-2.0"
18 LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=b26578452df1dcf3b9a63978282b72d0"
19
20 SRC_URI = "http://archive.apache.org/dist/qpid/proton/0.28.0/qpid-proton-0.28.0.tar.gz \
21            file://fix-missing-libary-for-cpp-binding.patch \
22           "
23
24 SRC_URI[sha256sum] = "224e599a4e965a016087b6ce683e55ca918493e12cdd6d91dac1c17d64a7dafe"
25
26 DEPENDS= "openssl swig-native python"
27
28 inherit cmake pkgconfig
29
30 EXTRA_OECMAKE = "-DCMAKE_INSTALL_PREFIX=/usr -DSYSINSTALL_BINDINGS=ON -DPYTHON_EXECUTABLE=`which python`"
31 BBCLASSEXTEND =+ " native"
32
33 PACKAGES =+ "\
34          ${PN}-cpp \
35          python-${PN} \
36          "
37
38 #FILES_qpid-proton-c = "${libdir}/libqpid-proton.so.*" 
39 #FILES_qpid-proton-c += "{libdir}/libqpid-proton-core.so.*" 
40 #FILES_qpid-proton-c += "${libdir}/libbqpid-proton-proactor.so.*" 
41
42 FILES_qpid-proton-cpp = "${libdir}/libqpid-proton-cpp.so.*" 
43 FILES_python-${PN} = "${libdir}/python*" 
44
45 RPROVIDES_${PN} = "qpid-proton-c"
46
47 do_install_append() {
48          rm -fr ${D}/usr/share
49 }