build_inf.sh: change the protocal for github repo
[pti/rtp.git] / meta-stx / recipes-support / puppet / puppetlabs-stdlib_git.bbappend
1 #
2 ## Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 #
17 # Copyright (C) 2019 Wind River Systems, Inc.
18 #
19 #  Licensed under the Apache License, Version 2.0 (the "License");
20 #  you may not use this file except in compliance with the License.
21 #  You may obtain a copy of the License at
22 #
23 #      http://www.apache.org/licenses/LICENSE-2.0
24 #
25 #  Unless required by applicable law or agreed to in writing, software
26 #  distributed under the License is distributed on an "AS IS" BASIS,
27 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
28 #  See the License for the specific language governing permissions and
29 #  limitations under the License.
30
31 FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
32
33 LICENSE = "Apache-2.0"
34 LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
35
36 SRCREV = "b89d5f388ca701e38a0e0337408f5ccb7e68565f"
37 PROTOCOL = "https"
38 BRANCH = "master"
39 PV = "4.18.0"
40
41 SRC_URI = " \
42         git://github.com/puppetlabs/puppetlabs-stdlib.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH} \
43         file://puppetlabs-stdlib/Add-gemspec.patch \
44         file://puppetlabs-stdlib/0001-Filter-password-in-logs.patch \
45         "
46
47 S = "${WORKDIR}/git"
48
49 RUBY_INSTALL_GEMS = "puppetlabs-stdlib-${PV}.gem"
50
51 do_install_append () {
52         install -d -m 0755 ${D}/${datadir}/puppet/modules/stdlib
53         tar -C ${S} -cf - --exclude "patches" --exclude "*.gem*" . | tar --no-same-owner -xf - -C ${D}/${datadir}/puppet/modules/stdlib
54 }
55
56 FILES_${PN} += " ${datadir}"
57
58 RDEPENDS_${PN}_append = " perl"