Add initial meta-stx to support StarlingX build
[pti/rtp.git] / meta-stx / recipes-support / puppet / puppetlabs-rabbitmq_git.bbappend
1 #
2 ## Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
17
18 SRC_URI += " \
19         file://${BPN}/0001-Roll-up-TIS-patches.patch \
20         file://${BPN}/0002-Changed-cipher-specification-to-openssl-format.patch \
21         file://${BPN}/0004-Partially-revert-upstream-commit-f7c3a4a637d59f3065d.patch \
22         file://${BPN}/0005-Remove-the-rabbitmq_nodename-fact.patch \
23         file://${BPN}/0007-init.pp-do-not-check-the-apt-resource.patch \
24         file://${BPN}/0008-puppet-rabbitmq-poky.patch \
25         file://${BPN}/0009-remove-apt-requirement.patch \
26         "
27
28 inherit openssl10
29
30 DEPENDS_append = " puppet-staging"