Add initial meta-stx to support StarlingX build
[pti/rtp.git] / meta-stx / recipes-support / puppet / puppetlabs-postgresql_git.bbappend
1 #
2 ## Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
17 SRC_URI += " \
18         file://${BPN}/0001-Roll-up-TIS-patches.patch \
19         file://${BPN}/0002-remove-puppetlabs-apt-as-a-requirement.patch \
20         file://${BPN}/0003-puppetlabs-postgresql-account-for-naming-diffs.patch \
21         file://${BPN}/0004-poky-postgresql-updates.patch \
22         file://${BPN}/0005-puppetlabs-postgresql-poky.patch \
23         file://${BPN}/0006-adjust_path-remove-refs-to-local-bin.patch \
24         file://${BPN}/postgresql.service \
25         "
26
27 #       file://${PN}/0004-postgresql-service-restart-with-systemctl.patch 
28
29 RDEPENDS_${PN}_append = " \
30         postgresql \
31         postgresql-contrib \
32         postgresql-client \
33         postgresql-timezone \
34         postgresql-plperl \
35         postgresql-plpython \
36         "
37 #postgresql-dev
38 #postgresql-pltcl
39 #postgresql-setup
40
41
42 do_install_append() {
43         install -d -m0755 ${D}/usr/lib/systemd/system
44         install -m0644 ${WORKDIR}/${PN}/postgresql.service ${D}/usr/lib/systemd/system
45 }
46
47 FILES_${PN}_append = " /usr/lib/systemd/system/postgresql.service"
48
49 inherit openssl10