Add initial meta-stx to support StarlingX build
[pti/rtp.git] / meta-stx / recipes-support / puppet / puppetlabs-lvm_git.bbappend
1 #
2 ## Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
17 SRC_URI += " \
18         file://${PN}/0001-puppet-lvm-kilo-quilt-changes.patch;striplevel=5 \
19         file://${PN}/0002-UEFI-pvcreate-fix.patch;striplevel=5 \
20         file://${PN}/0003-US94222-Persistent-Dev-Naming.patch;striplevel=5 \
21         file://${PN}/0004-extendind-nuke_fs_on_resize_failure-functionality.patch;striplevel=5 \
22         file://${PN}/Fix-the-logical-statement-for-nuke_fs_on_resize.patch;striplevel=5 \
23         "
24 RDEPENDS_${PN} += " \
25         lvm2 \
26         lvm2-scripts \
27         lvm2-udevrules \
28         "
29
30 inherit openssl10