Add initial meta-stx to support StarlingX build
[pti/rtp.git] / meta-stx / recipes-support / puppet / puppetlabs-create-resources_git.bb
1 #
2 # Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 SUMMARY = "Function to dynamically create resources from hashes."
17
18 LICENSE = "Apache-2.0"
19 LIC_FILES_CHKSUM = "file://LICENSE;md5=6089b6bd1f0d807edb8bdfd76da0b038 "
20
21 PV = "0.0.1"
22 STABLE = "master"
23 PROTOCOL = "https"
24 BRANCH = "master"
25 SRCREV = "4639819a7f3a4fa9310d2ba583c63e467df7e2c3"
26 S = "${WORKDIR}/git"
27
28
29 SRC_URI = " \
30         git://github.com/puppetlabs/puppetlabs-create_resources.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH} \
31         file://${PN}/Add-gemspec.patch \
32         file://${PN}/metadata.json.patch \
33         "
34 inherit ruby
35
36 DEPENDS += " \
37         ruby \
38         facter \
39         "
40
41 RDEPENDS_${PN} += " \
42         ruby \
43         facter \
44         puppet \
45         perl \
46         "
47
48 RUBY_INSTALL_GEMS = "${PN}-${PV}.gem"
49
50 do_install_append () {
51         install -d -m 0755 ${D}/${datadir}/puppet/modules/create_resources
52         tar -C ${S} -cf - --exclude "patches" --exclude "*.gem*" . | tar --no-same-owner -xf - -C ${D}/${datadir}/puppet/modules/create_resources
53 }
54
55 FILES_${PN} += " ${datadir}"