Add initial meta-stx to support StarlingX build
[pti/rtp.git] / meta-stx / recipes-support / puppet / puppetlabs-apache_git.bbappend
1 #
2 ## Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
17 SRC_URI += " \
18         file://${BPN}/puppetlabs-apache-updates-for-poky-stx.patch \
19         "
20 #SRC_URI += " \
21 #       file://${BPN}/0001-maint-Fix-conditional-in-vhost-ssl-template.patch \
22 #       file://${BPN}/0002-maint-Fix-the-vhost-ssl-template-correctly-this-time.patch \
23 #       "
24
25 RDEPENDS_${PN} += " \
26         apache2 \
27         mod-wsgi \
28         "
29
30 inherit openssl10