Add initial meta-stx to support StarlingX build
[pti/rtp.git] / meta-stx / recipes-support / puppet / puppet-staging_git.bb
1 #
2 # Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 SUMMARY = "Manages staging directory, along with download/extraction of compressed files."
17
18 LICENSE = "Apache-2.0"
19 LIC_FILES_CHKSUM = "file://LICENSE;md5=cdbf8d74b765504fbdf8e154bb4458a1"
20
21 PV = "1.0.4"
22 SRCREV = "bc434a71e19aae54223d57c274e2e1a7f9546d5e"
23 PROTOCOL = "https"
24 BRANCH = "master"
25 S = "${WORKDIR}/git"
26
27 SRC_URI = " \
28         git://github.com/nanliu/puppet-staging;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH} \
29         file://puppet-staging/Add-gemspec.patch \
30         "
31
32 inherit ruby
33
34 DEPENDS += " \
35         ruby \
36         facter \
37         "
38
39 RDEPENDS_${PN} += " \
40         ruby \
41         facter \
42         puppet \
43         perl \
44         "
45
46 RUBY_BUILD_GEMS = "nanliu-staging.gemspec"
47 RUBY_INSTALL_GEMS = "nanliu-staging-${PV}.gem"
48
49 do_install_append() {
50         install -d -m 0755 ${D}/${datadir}/puppet/modules/staging
51         tar -C ${S} -cf - --exclude "patches" --exclude "*.gem*" . | tar --no-same-owner -xf - -C ${D}/${datadir}/puppet/modules/staging
52 }
53
54 FILES_${PN} += " ${datadir}"