build_inf.sh: change the protocal for github repo
[pti/rtp.git] / meta-stx / recipes-support / puppet / puppet-puppi_git.bb
1 #
2 # Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 SUMMARY = "Installs and configures Puppi."
17 DESCRIPTION = " \
18         This module provides the Puppi libraries required by Example42 modules and, if explicitely included, the \
19         puppi command, its working environment, the defines and procedures to deploy applications.\
20         "
21
22 LICENSE = "Apache-2.0"
23 LIC_FILES_CHKSUM = "file://LICENSE;md5=a300b604c66de62cf6e923cca89c9d83"
24
25 PV = "2.2.3"
26 SRCREV = "c1c47f4edfd761d1bbde32a75da0c3fa7cc93a81"
27 PROTOCOL = "https"
28 BRANCH = "master"
29 S = "${WORKDIR}/git"
30
31 SRC_URI = " \
32         git://github.com/example42/puppi;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH} \
33         file://${PN}/Add-gemspec.patch \
34         " 
35
36 inherit ruby 
37
38 DEPENDS += " \
39         ruby \
40         facter \
41         "
42
43 RDEPENDS_${PN} += " \
44         ruby \
45         facter \
46         puppet \
47         perl \
48         "
49
50 RUBY_INSTALL_GEMS = "${PN}-${PV}.gem"
51
52 do_install_append() {
53         install -d -m 0755 ${D}/${datadir}/puppet/modules/puppi
54         tar -C ${S} -cf - --exclude "patches" --exclude "*.gem*" . | tar --no-same-owner -xf - -C ${D}/${datadir}/puppet/modules/puppi
55 }
56
57 FILES_${PN} += " ${datadir}"