Add initial meta-stx to support StarlingX build
[pti/rtp.git] / meta-stx / recipes-support / puppet / puppet-nssdb_git.bb
1 #
2 # Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 SUMMARY = "NSS database Puppet Module"
17
18 LICENSE = "Apache-2.0"
19 LIC_FILES_CHKSUM = "file://LICENSE;md5=0409d65ae3bec182108fd45c64bd0ef2"
20
21 PV = "1.0.1"
22 SRCREV = "2e163a21fb80d828afede2d4be6214f1171c4887"
23 PROTOCOL = "https"
24 BRANCH = "master"
25 S = "${WORKDIR}/git"
26
27 SRC_URI = "git://github.com/rcritten/puppet-nssdb.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH} \
28         file://${PN}/Add-gemspec.patch \
29         file://${PN}/metadata.json.patch \
30         "
31
32 inherit ruby
33
34 DEPENDS += " \
35         ruby \
36         facter \
37         "
38
39 RDEPENDS_${PN} += " \
40         ruby \
41         facter \
42         puppet \
43         perl \
44         "
45
46 RUBY_INSTALL_GEMS = "puppet-nssdb-${PV}.gem"
47
48 do_install_append() {
49         install -d -m 0755 ${D}/${datadir}/puppet/modules/nssdb
50         tar -C ${S} -cf - --exclude "patches" --exclude "*.gem*" . | tar --no-same-owner -xf - -C ${D}/${datadir}/puppet/modules/nssdb
51 }
52
53 FILES_${PN} += " ${datadir}"