puppet-network: add vlan support for poky-stx.rb
[pti/rtp.git] / meta-stx / recipes-support / puppet / puppet-network_git.bbappend
1 #
2 ## Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
17 SRC_URI += " \
18         file://${BPN}/puppet-network-Kilo-quilt-changes.patch;striplevel=5 \
19         file://${BPN}/puppet-network-support-ipv6.patch;striplevel=5 \
20         file://${BPN}/Don-t-write-absent-to-redhat-route-files-and-test-fo.patch;striplevel=5 \
21         file://${BPN}/fix-absent-options.patch;striplevel=5 \
22         file://${BPN}/permit-inservice-update-of-static-routes.patch;striplevel=5 \
23         file://${BPN}/ipv6-static-route-support.patch;striplevel=5 \
24         file://${BPN}/route-options-support.patch;striplevel=5 \
25         file://${BPN}/0001-Stx-uses-puppet-boolean-instead-of-adrien-boolean.patch \
26         file://${BPN}/puppet-network-updates-for-poky-stx.patch \
27         file://${BPN}/puppet-network-config-poky-provider.patch \
28         file://${BPN}/puppet-network-poky-stx.rb-add-vlan-support.patch \
29         " 
30
31 inherit openssl10
32
33 do_configure_append() {
34         rm -f spec/fixtures/modules/network/files
35 }
36
37 RDEPENDS_${PN} += "\
38         vlan \
39 "