Add initial meta-stx to support StarlingX build
[pti/rtp.git] / meta-stx / recipes-support / puppet / puppet-network_git.bb
1 #
2 # Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 SUMMARY = "A Puppet module to manage non volatile network and route configuration."
17
18 LICENSE = "Apache-2.0"
19 LIC_FILES_CHKSUM = "file://LICENSE;md5=b43880e14353cbc12cf3981fb93a0944"
20
21
22 PV = "0.5.0"
23 SRCREV = "7deacd5fdc22c0543455878a8d1872f2f5417c1d"
24 PROTOCOL = "https"
25 BRANCH = "master"
26 S = "${WORKDIR}/git"
27
28 SRC_URI = " \
29         git://github.com/voxpupuli/puppet-network;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH} \
30         file://puppet-network/Add-gemspec.patch \
31         file://puppet-network/metadata.json.patch \
32         " 
33
34 inherit ruby 
35
36 DEPENDS += " \
37         ruby \
38         facter \
39         "
40
41 RDEPENDS_${PN} += " \
42         ruby \
43         facter \
44         puppet \
45         perl \
46         "
47
48 RUBY_INSTALL_GEMS = "${PN}-${PV}.gem"
49
50
51 do_install_append() {
52         install -d -m 0755 ${D}/${datadir}/puppet/modules/network
53         tar -C ${S} -cf - --exclude "patches" --exclude "*.gem*" . | tar --no-same-owner -xf - -C ${D}/${datadir}/puppet/modules/network
54         # Remove broken symlinks for now
55         rm -f ${D}/${libdir}/ruby/gems/2.5.0/gems/puppet-network-0.5.0/spec/fixtures/modules/network/manifests
56         rm -f ${D}/${libdir}/ruby/gems/2.5.0/gems/puppet-network-0.5.0/spec/fixtures/modules/network/templates
57         rm -f ${D}/${libdir}/ruby/gems/2.5.0/gems/puppet-network-0.5.0/spec/fixtures/modules/network/files
58         rm -f ${D}/${libdir}/ruby/gems/2.5.0/gems/puppet-network-0.5.0/spec/fixtures/modules/network/lib
59         rm -f ${D}/${datadir}/puppet/modules/network/spec/fixtures/modules/network/files
60 }
61
62 FILES_${PN} += " ${datadir}"