Add initial meta-stx to support StarlingX build
[pti/rtp.git] / meta-stx / recipes-support / puppet / puppet-memcached_git.bb
1 #
2 # Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 SUMMARY = "Intended managing the entirety of horizon."
17 DESCRIPTION = " \
18         The horizon module is a thorough attempt to make Puppet capable of \
19         managing the entirety of horizon. Horizon is a fairly classic django \
20         application, which results in a fairly simply Puppet module.\
21         "
22
23 HOMEPAGE = "https://github.com/saz/puppet-memcached.git"
24 LICENSE = "Apache-2.0"
25 LIC_FILES_CHKSUM = "file://LICENSE;md5=1322039bbc8e3ff4e74252ec65303861"
26
27 PV = "3.0.2"
28 SRCREV = "c2a0b543dc28f34ab68e905ede3173b00246ddca"
29 PROTOCOL = "https"
30 BRANCH = "master"
31 S = "${WORKDIR}/git"
32
33 SRC_URI = " \
34         git://github.com/saz/puppet-memcached.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH} \
35         file://puppet-memcached/Add-gemspec.patch \
36         "
37
38 inherit ruby
39
40 DEPENDS += " \
41         ruby \
42         facter \
43         "
44
45 RDEPENDS_${PN} += " \
46         ruby \
47         facter \
48         puppet \
49         perl \
50         "
51
52 RUBY_INSTALL_GEMS = "puppet-memcached-${PV}.gem"
53
54 do_install_append() { 
55         install -d -m 0755 ${D}/${datadir}/puppet/modules/memcached
56         tar -C ${S} -cf - --exclude "patches" --exclude "*.gem*" . | tar --no-same-owner -xf - -C ${D}/${datadir}/puppet/modules/memcached
57 }
58
59 FILES_${PN} += " ${datadir}"