Add initial meta-stx to support StarlingX build
[pti/rtp.git] / meta-stx / recipes-support / puppet / puppet-ldap_git.bb
1 #
2 # Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 SUMMARY = "OpenLDAP module for Puppet."
17
18 LICENSE = "GPLv2"
19 LIC_FILES_CHKSUM = "file://metadata.json;md5=4244fe391bee02e9ee7259aa7f8dda8b"
20
21 PV = "0.2.4"
22 SRCREV = "480f13af6d17d1d3fcf0dc7b4bd04b49fa4099e1"
23 PROTOCOL = "https"
24 BRANCH = "master"
25 S = "${WORKDIR}/git"
26
27 SRC_URI = " \
28         git://github.com/torian/puppet-ldap;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH} \
29         file://puppet-ldap/Add-gemspec.patch \
30         "
31 inherit ruby 
32
33 DEPENDS += " \
34         ruby \
35         facter \
36         "
37
38 RDEPENDS_${PN} += " \
39         ruby \
40         facter \
41         puppet \
42         perl \
43         "
44
45 RUBY_INSTALL_GEMS = "${PN}-${PV}.gem"
46
47 do_install_append() {
48         install -d -m 0755 ${D}/${datadir}/puppet/modules/ldap
49         tar -C ${S} -cf - --exclude "patches" --exclude "*.gem*" . | tar --no-same-owner -xf - -C ${D}/${datadir}/puppet/modules/ldap
50 }
51
52 FILES_${PN} += " ${datadir}"