Add initial meta-stx to support StarlingX build
[pti/rtp.git] / meta-stx / recipes-support / puppet / puppet-keystone_git.bbappend
1 #
2 ## Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
17 SRC_URI += " \
18         file://${PN}/0001-pike-rebase-squash-titanium-patches.patch \
19         file://${PN}/0002-remove-the-Keystone-admin-app.patch \
20         file://${PN}/0003-remove-eventlet_bindhost-from-Keystoneconf.patch \
21         file://${PN}/0004-escape-special-characters-in-bootstrap.patch \
22         file://${PN}/0005-Add-support-for-fernet-receipts.patch \
23         file://${PN}/0007-puppet-keystone-specify-full-path-to-openrc.patch \
24         file://${PN}/0008-params.pp-fix-the-service-name-of-openstack-keystone.patch \
25         "
26
27 do_install_append () {
28         # fix the name of python-memcached
29         sed -i -e 's/python-memcache\b/python-memcached/' ${D}/${datadir}/puppet/modules/keystone/manifests/params.pp
30 }
31
32 RDEPENDS_${PN} += " \
33         python-memcached \
34         python-ldappool \
35         "
36
37 inherit openssl10