Add initial meta-stx to support StarlingX build
[pti/rtp.git] / meta-stx / recipes-support / puppet / puppet-horizon_git.bb
1 #
2 # Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 SUMMARY = "Intended managing the entirety of horizon."
17 DESCRIPTION = " \
18         The horizon module is a thorough attempt to make Puppet capable of \
19         managing the entirety of horizon. Horizon is a fairly classic django \
20         application, which results in a fairly simply Puppet module.\
21         "
22
23 # HOMEPAGE = "https://github.com/openstack/puppet-horizon"
24 LICENSE = "Apache-2.0"
25 LIC_FILES_CHKSUM = "file://LICENSE;md5=12a15a9ebddda7d856c783f745e5ee47"
26
27 PV = "11.5.0"
28 SRCREV = "d75706e38fdf63f9c3174a526a7d07799390dfeb"
29 PROTOCOL = "https"
30 BRANCH = "stable/pike"
31 S = "${WORKDIR}/git"
32
33 SRC_URI = "git://github.com/openstack/puppet-horizon.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH} \
34         file://${PN}/Add-gemspec.patch \
35         "
36
37 inherit ruby
38
39 DEPENDS += " \
40         ruby \
41         facter \
42         "
43
44 RDEPENDS_${PN} += " \
45         ruby \
46         facter \
47         puppet \
48         perl \
49         "
50
51 RUBY_INSTALL_GEMS = "puppet-horizon-${PV}.gem"
52
53 do_install_append() { 
54         install -d -m 0755 ${D}/${datadir}/puppet/modules/horizon
55         tar -C ${S} -cf - --exclude "patches" --exclude "*.gem*" . | tar --no-same-owner -xf - -C ${D}/${datadir}/puppet/modules/horizon
56 }
57
58 FILES_${PN} += " ${datadir}"