Add initial meta-stx to support StarlingX build
[pti/rtp.git] / meta-stx / recipes-support / puppet / puppet-filemapper_git.bb
1 #
2 # Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 DESCRIPTION = "A Puppet module to map files to resources and back."
17
18 LICENSE = "Apache-2.0"
19 LIC_FILES_CHKSUM = "file://LICENSE;md5=b43880e14353cbc12cf3981fb93a0944"
20
21 PV = "1.1.3"
22 SRCREV = "9b53310278e76827bbe12a36cc6470d77071abb2"
23 PROTOCOL = "https"
24 BRANCH = "master"
25 S = "${WORKDIR}/git"
26
27 SRC_URI = " \
28         git://github.com/adrienthebo/puppet-filemapper;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH} \
29         file://${PN}/Add-gemspec.patch \
30         file://${PN}/metadata.json.patch \
31         " 
32
33 inherit ruby 
34
35 DEPENDS += " \
36         ruby \
37         facter \
38         "
39
40 RDEPENDS_${PN} += " \
41         ruby \
42         facter \
43         puppet \
44         perl \
45         "
46
47 RUBY_BUILD_GEMS = "adrien-filemapper.gemspec"
48 RUBY_INSTALL_GEMS = "adrien-filemapper-${PV}.gem"
49
50 do_install_append() {
51         install -d -m 0755 ${D}/${datadir}/puppet/modules/filemapper
52         tar -C ${S} -cf - --exclude "patches" --exclude "*.gem*" . | tar --no-same-owner -xf - -C ${D}/${datadir}/puppet/modules/filemapper
53 }
54
55 FILES_${PN} += " ${datadir}"