Add initial meta-stx to support StarlingX build
[pti/rtp.git] / meta-stx / recipes-support / puppet / puppet-drbd_git.bbappend
1 #
2 ## Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
17 SRC_URI += " \
18         file://${PN}/0001-TIS-Patches.patch \
19         file://${PN}/0002-Disable-timeout-for-mkfs-command.patch \
20         file://${PN}/0003-drbd-parallel-to-serial-synchronization.patch \
21         file://${PN}/0004-US-96914-reuse-existing-drbd-cinder-resource.patch \
22         file://${PN}/0005-Add-PausedSync-states-to-acceptable-cstate.patch \
23         file://${PN}/0006-CGTS-7164-Add-resource-options-cpu-mask-to-affine-drbd-kernel-threads.patch \
24         file://${PN}/0007-Add-disk-by-path-test.patch \
25         file://${PN}/0008-CGTS-7953-support-for-new-drbd-resources.patch \
26         file://${PN}/0009-drbd-slow-before-swact.patch \
27         "
28
29 inherit openssl10