Add initial meta-stx to support StarlingX build
[pti/rtp.git] / meta-stx / recipes-support / puppet / puppet-drbd_git.bb
1 #
2 # Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 DESCRIPTION = "puppet-drbd"
17
18 PV = "0.3.1"
19 SRCREV = "496b3ba9cd74a2d12636f9e90a718739a5451169"
20 PROTOCOL = "https"
21 BRANCH = "master"
22 S = "${WORKDIR}/git"
23
24 LICENSE = "Apache-2.0"
25
26 LIC_FILES_CHKSUM = "file://LICENSE;md5=6089b6bd1f0d807edb8bdfd76da0b038 "
27
28 SRC_URI = " \
29         git://github.com/voxpupuli/puppet-drbd;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH} \
30         file://${PN}/Add-gemspec.patch \
31         "
32 inherit ruby 
33
34 DEPENDS += " \
35         ruby \
36         facter \
37         "
38
39 RDEPENDS_${PN} += " \
40         ruby \
41         facter \
42         puppet \
43         perl \
44         "
45
46 RUBY_INSTALL_GEMS = "${PN}-${PV}.gem"
47
48 do_install_append() {
49         install -d -m 0755 ${D}/${datadir}/puppet/modules/drbd
50         tar -C ${S} -cf - --exclude "patches" --exclude "*.gem*" . | tar --no-same-owner -xf - -C ${D}/${datadir}/puppet/modules/drbd
51 }
52
53 FILES_${PN} += "${datadir}"