Add initial meta-stx to support StarlingX build
[pti/rtp.git] / meta-stx / recipes-support / puppet / puppet-dnsmasq_git.bb
1 #
2 # Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 DESCRIPTION = "puppet module for dnsmasq"
17
18 LICENSE = "Apache-2.0"
19 LIC_FILES_CHKSUM = "file://README.md;md5=71e3bfa9ffc5e93324727bbffae917f5"
20
21 PV = "1.1.0"
22 STABLE = "master"
23 PROTOCOL = "https"
24 BRANCH = "master"
25 SRCREV = "cff07e90890662972c97684a2baee964f68ff3ed"
26 S = "${WORKDIR}/git"
27
28 SRC_URI = "git://github.com/netmanagers/puppet-dnsmasq;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH} \
29         file://${PN}/Add-gemspec.patch \
30         file://${PN}/metadata.json.patch \
31         "
32 inherit ruby
33
34 DEPENDS += " \
35         ruby \
36         facter \
37         "
38
39 RDEPENDS_${PN} += " \
40         ruby \
41         facter \
42         puppet \
43         perl \
44         "
45
46 RUBY_INSTALL_GEMS = "${PN}-${PV}.gem"
47
48 do_install_append () {
49         install -d -m 0755 ${D}/${datadir}/puppet/modules/dnsmasq
50         tar -C ${S} -cf - --exclude "patches" --exclude "*.gem*" . | tar --no-same-owner -xf - -C ${D}/${datadir}/puppet/modules/dnsmasq/
51 }
52
53 FILES_${PN} += " ${datadir}"