Add initial meta-stx to support StarlingX build
[pti/rtp.git] / meta-stx / recipes-support / puppet / puppet-collectd_git.bb
1 #
2 # Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 SUMMARY = "Puppet module for configuring collectd and plugins."
17
18 LICENSE = "Apache-2.0"
19 LIC_FILES_CHKSUM = "file://LICENSE;md5=03ff50a0bc4a15eb462d4129e89f9656"
20
21 PV = "5.1.0"
22 SRCREV = "f5a44db033c7cea9990c405519f70d18fc2b05c0"
23 PROTOCOL = "https"
24 BRANCH = "master"
25 S = "${WORKDIR}/git"
26
27 SRC_URI = "git://github.com/voxpupuli/puppet-collectd;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH} \
28         file://${PN}/Add-gemspec.patch \
29         "
30
31 inherit ruby
32
33 DEPENDS += " \
34         ruby \
35         facter \
36         "
37
38 RDEPENDS_${PN} += " \
39         ruby \
40         facter \
41         puppet \
42         perl \
43         "
44
45 RUBY_INSTALL_GEMS = "${PN}-${PV}.gem"
46
47
48 do_install_append() {
49         install -d -m 0755 ${D}/${datadir}/puppet/modules/collectd
50         tar -C ${S} -cf - --exclude "patches" --exclude "*.gem*" . | tar --no-same-owner -xf - -C ${D}/${datadir}/puppet/modules/collectd
51 }
52
53 FILES_${PN} += " ${datadir}"