Add initial meta-stx to support StarlingX build
[pti/rtp.git] / meta-stx / recipes-support / puppet / puppet-certmonger_git.bb
1 #
2 # Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 SUMMARY = "Deprecated: Use saltedsignal/puppet-certmonger instead."
17 DESCRIPTION = " \
18         This puppet module allows you to request and manage certificates using certmonger. \
19         "
20
21 LICENSE = "Apache-2.0"
22 LIC_FILES_CHKSUM = "file://LICENSE;md5=5e8f921d6b978d3605270db1f39e199f"
23
24 PV = "1.1.1"
25 SRCREV = "1157a7e552d87696e80ed4ab54bf0608a1c5ffff"
26 PROTOCOL = "https"
27 BRANCH = "master"
28 S = "${WORKDIR}/git"
29
30 SRC_URI = "git://github.com/earsdown/puppet-certmonger.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH} \
31         file://puppet-certmonger/Add-gemspec.patch \
32         "
33
34 inherit ruby
35
36 DEPENDS += " \
37         ruby \
38         facter \
39         "
40
41 RDEPENDS_${PN} += " \
42         ruby \
43         facter \
44         puppet \
45         perl \
46         "
47
48 RUBY_INSTALL_GEMS = "puppet-certmonger-${PV}.gem"
49
50 do_install_append() {
51         install -d -m 0755 ${D}/${datadir}/puppet/modules/certmonger
52         tar -C ${S} -cf - --exclude "patches" --exclude "*.gem*" . | tar --no-same-owner -xf - -C ${D}/${datadir}/puppet/modules/certmonger
53 }
54
55 FILES_${PN} += " ${datadir}"