Add initial meta-stx to support StarlingX build
[pti/rtp.git] / meta-stx / recipes-support / puppet / puppet-ceph_git.bbappend
1 #
2 ## Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
17 SRC_URI += " \
18         file://${BPN}/0001-Roll-up-TIS-patches.patch \
19         file://${BPN}/0002-Newton-rebase-fixes.patch \
20         file://${BPN}/0003-Ceph-Jewel-rebase.patch \
21         file://${BPN}/0004-US92424-Add-OSD-support-for-persistent-naming.patch \
22         file://${BPN}/0005-Remove-puppetlabs-apt-as-ceph-requirement.patch \
23         file://${BPN}/0006-ceph-disk-prepare-invalid-data-disk-value.patch \
24         file://${BPN}/0007-Add-StarlingX-specific-restart-command-for-Ceph-moni.patch \
25         file://${BPN}/0008-ceph-mimic-prepare-activate-osd.patch \
26         file://${BPN}/0009-fix-ceph-osd-disk-partition-for-nvme-disks.patch \
27         file://${BPN}/0010-wipe-unprepared-disks.patch \
28         file://${BPN}/0011-puppet-ceph-changes-for-poky-stx.patch \
29         "
30 inherit openssl10