Add initial meta-stx to support StarlingX build
[pti/rtp.git] / meta-stx / recipes-support / puppet / puppet-boolean_git.bb
1 #
2 # Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 DESCRIPTION = "Logical Resource Management (LVM) features for Puppet."
17
18 LICENSE = "Apache-2.0"
19 LIC_FILES_CHKSUM = "file://LICENSE;md5=8cbd44f4ffbc81632df22fdd4ae87811"
20
21 PV = "1.0.1"
22 SRCREV = "22b726dd78b0a60a224cc7054aebbf28e9306f62"
23 PROTOCOL = "https"
24 BRANCH = "master"
25 S = "${WORKDIR}/git"
26
27 SRC_URI = "git://github.com/adrienthebo/puppet-boolean;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH} \
28         file://${PN}/Add-gemspec.patch \
29         "
30 inherit ruby
31
32 DEPENDS += " \
33         ruby \
34         facter \
35         "
36
37 RDEPENDS_${PN} += " \
38         ruby \
39         facter \
40         puppet \
41         perl \
42         "
43
44 RUBY_INSTALL_GEMS = "${PN}-${PV}.gem"
45
46
47 do_install_append() {
48         install -d -m 0755 ${D}/${datadir}/puppet/modules/boolean
49         tar -C ${S} -cf - --exclude "patches" --exclude "*.gem*" . | tar --no-same-owner -xf - -C ${D}/${datadir}/puppet/modules/boolean/
50 }
51
52 FILES_${PN} += " ${datadir}"