Add initial meta-stx to support StarlingX build
[pti/rtp.git] / meta-stx / recipes-support / puppet / puppet-barbican_git.bb
1 #
2 # Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 SUMMARY = "Puppet module for OpenStack Barbican"
17
18 LICENSE = "Apache-2.0"
19 LIC_FILES_CHKSUM = "file://LICENSE;md5=fce88ac1cd1315adf28a52502c9f7f6b"
20
21 RDEPENDS_${PN} += " \
22         puppetlabs-inifile \
23         "
24
25 PV = "11.3.0"
26 SRCREV = "8241a1d13be6c3ee6344fa46dcfc045439044e76"
27 PROTOCOL = "https"
28 BRANCH = "stable/pike"
29 S = "${WORKDIR}/git"
30
31 SRC_URI = "git://github.com/openstack/puppet-barbican.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH} \
32         file://puppet-barbican/Add-gemspec.patch \
33         "
34
35 inherit ruby
36
37 DEPENDS += " \
38         ruby \
39         facter \
40         "
41
42 RDEPENDS_${PN} += " \
43         ruby \
44         facter \
45         puppet \
46         perl \
47         "
48
49 RUBY_INSTALL_GEMS = "puppet-barbican-${PV}.gem"
50
51 do_install_append() {
52         install -d -m 0755 ${D}/${datadir}/puppet/modules/barbican
53         tar -C ${S} -cf - --exclude "patches" --exclude "*.gem*" . | tar --no-same-owner -xf - -C ${D}/${datadir}/puppet/modules/barbican
54 }
55
56 FILES_${PN} += " ${datadir}"