Add initial meta-stx to support StarlingX build
[pti/rtp.git] / meta-stx / recipes-support / os-service-types / python2-os-service-types_1.3.0.bb
1 #
2 # Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 DESCRIPTION = "A library to handle official service types for OpenStack and their historical aliases."
17 HOMEPAGE = "https://opendev.org/openstack/os-service-types"
18 SECTION = "devel/python"
19 LICENSE = "Apache-2.0"
20 LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
21
22 STABLE = "master"
23 PROTOCOL = "https"
24 BRANCH = "master"
25 SRCREV = "2e5b38088a43539621de82aa2d0c1b366c2638a9"
26 S = "${WORKDIR}/git"
27
28 SRC_URI = "git://opendev.org/openstack/os-service-types.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH}"
29
30 inherit setuptools 
31
32 DEPENDS += " \
33         python-pip \
34         python-pbr-native \
35         "
36
37 RDEPENDS_${PN} += " \
38         python-lxml \
39         python-requests \
40         python-cython \
41         "