Add initial meta-stx to support StarlingX build
[pti/rtp.git] / meta-stx / recipes-support / libverto / libverto_0.2.5.bb
1 #
2 # Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 SUMMARY = "Event loop abstraction for Libraries"
17 DESCRIPTION = "Libverto exists to isolate libraries from the particular event loop \
18 chosen by an application. Libverto provides an asynchronous \
19 programming interface independent of any particular event loop and \
20 allows applications to attach this interface to whatever event loop \
21 they select."
22 HOMEPAGE = "http://fedorahosted.net/libverto"
23
24 LICENSE = "MIT"
25 LIC_FILES_CHKSUM = "file://COPYING;md5=bc8917ab981cfa6161dc29319a4038d9"
26
27
28 DEPENDS += "libevent libtevent"
29
30 # fedorahosted tarball cannot be fetched completely, so switch to use other source
31 # SRC_URI = "http://fedorahosted.org/releases/l/i/${PN}/${PN}-${PV}.tar.gz"
32 SRC_URI = "https://github.com/latchset/libverto/releases/download/0.2.5/${PN}-${PV}.tar.gz \
33           "
34 SRC_URI[md5sum] = "144fb8f00759ef8ad71c472333847f03"
35
36 inherit autotools pkgconfig
37
38 PACKAGECONFIG ??= "libevent tevent"
39 PACKAGECONFIG[glib] = "--with-glib,--without-glib,glib-2.0"
40 PACKAGECONFIG[libev] = "--with-libev,--without-libev,libev"
41 PACKAGECONFIG[libevent] = "--with-libevent,--without-libevent,libevent"
42 PACKAGECONFIG[tevent] = "--with-tevent,--without-tevent,libtevent"
43
44 PACKAGES =+ "${PN}-libevent ${PN}-tevent"
45
46 FILES_${PN}-libevent = "${libdir}/libverto-libevent${SOLIBS}"
47 FILES_${PN}-tevent = "${libdir}/libverto-tevent${SOLIBS}"
48
49 RPROVIDES_${PN}-libevent += "${PN}-module-base"
50 RPROVIDES_${PN}-tevent += "${PN}-module-base"
51