Add initial meta-stx to support StarlingX build
[pti/rtp.git] / meta-stx / recipes-support / libtpms / libtpms_git.bb
1 #
2 # Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 DESCRIPTION = "\
17                 "
18
19 LICENSE = "BSD"
20 LIC_FILES_CHKSUM = "file://LICENSE;md5=e73f0786a936da3814896df06ad225a9"
21
22 SRCREV = "f74b7104c0124db56c123ed171f378e82bd207c2"
23 PROTOCOL = "https"
24 BRANCH = "stable-0.6.0"
25 S = "${WORKDIR}/git"
26
27 SRC_URI = "git://github.com/stefanberger/libtpms.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH}"
28
29 DEPENDS += " tpm2-tss tpm2-tools tpm2-abrmd openssh openssl"
30
31 inherit autotools
32
33 EXTRA_OECONF += "--with-openssl --with-tpm2"