Add initial meta-stx to support StarlingX build
[pti/rtp.git] / meta-stx / recipes-support / libtommath / libtommath_1.1.0.bb
1 #
2 # Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 SUMMARY = "A portable number theoretic multiple-precision integer library"
17 DESCRIPTION = " \
18   A free open source portable number theoretic multiple-precision integer \
19   library written entirely in C. (phew!). The library is designed to provide \
20   a simple to work with API that provides fairly efficient routines that \
21   build out of the box without configuration. \
22 "
23 HOMEPAGE = "https://github.com/libtom/libtommath"
24
25 LICENSE = "PD"
26 LIC_FILES_CHKSUM = "file://LICENSE;md5=23e7e0a32e53a2b1d35f5fd9ef053402"
27
28 DEPENDS = "libtool-cross"
29
30 SRC_URI = "https://github.com/libtom/libtommath/releases/download/v${PV}/ltm-${PV}.tar.xz"
31
32 SRC_URI[md5sum] = "b2da4488c9024976d36870132f4b8a42"
33 SRC_URI[sha256sum] = "90466c88783d1fe9f5c2364a69f5479f10d73ed616011be6196f35f7f1537ead"
34
35 EXTRA_OEMAKE = " \
36         LIBTOOL=${STAGING_BINDIR_CROSS}/${HOST_SYS}-libtool \
37         LIBPATH=${libdir} \
38         INCPATH=${includedir} \
39         -f makefile.shared \
40         "
41
42 do_install() {
43         oe_runmake install DESTDIR=${D}
44 }