libevent: add version 2.0.21 to align with stx 3.0
[pti/rtp.git] / meta-stx / recipes-support / libevent / libevent_2.0.21.bb
1 #
2 ## Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 SUMMARY = "An asynchronous event notification library"
17 HOMEPAGE = "http://libevent.org/"
18 BUGTRACKER = "https://github.com/libevent/libevent/issues"
19 SECTION = "libs"
20
21 LICENSE = "BSD"
22 LIC_FILES_CHKSUM = "file://LICENSE;md5=45c5316ff684bcfe2f9f86d8b1279559"
23
24 SRC_URI = " \
25     https://github.com/downloads/libevent/libevent/${BP}-stable.tar.gz \
26     file://libevent-obsolete_automake_macros.patch \
27     file://libevent-disable_tests.patch \
28     file://libevent-ipv6-client-socket.patch \
29 "
30
31 SRC_URI[md5sum] = "b2405cc9ebf264aa47ff615d9de527a2"
32 SRC_URI[sha256sum] = "22a530a8a5ba1cb9c080cba033206b17dacd21437762155c6d30ee6469f574f5"
33
34 S = "${WORKDIR}/${BP}-stable"
35
36 inherit openssl10
37
38 PACKAGECONFIG ??= "openssl"
39 PACKAGECONFIG[openssl] = "--enable-openssl,--disable-openssl,openssl10"
40
41 inherit autotools
42
43 # Needed for Debian packaging
44 LEAD_SONAME = "libevent-2.0.so"
45
46 BBCLASSEXTEND = "native nativesdk"