build_inf.sh: change the protocal for github repo
[pti/rtp.git] / meta-stx / recipes-support / hardlink / hardlink_0.3.0.bb
1 #
2 # Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 DESCRIPTION = "Hardlink is a tool which replaces multiple copies of a file with hardlinks"
17
18 HOMEPAGE = "https://jak-linux.org/projects/hardlink"
19 LICENSE = "MIT"
20 LIC_FILES_CHKSUM = "file://hardlink.1;md5=c7a9a3326f28fa218d9af0251a5e1ae4"
21
22 SRC_URI = "https://jak-linux.org/projects/hardlink/hardlink_0.3.0.tar.xz"
23 SRC_URI[md5sum] = "72f1a460adb6874c151deab766e434ad"
24 SRC_URI[sha256sum] = "e8c93dfcb24aeb44a75281ed73757cb862cc63b225d565db1c270af9dbb7300f"
25
26 DEPENDS = " attr"
27 inherit pkgconfig
28
29 do_install() {
30         cd ${S}
31         oe_runmake -e DESTDIR=${D} BINDIR=${bindir} MANDIR=${datadir} install
32 }
33
34 FILES_${PN}-doc = "${datadir}/"