11b7e8272888b2670b7257a23b372d89c384c6d8
[pti/rtp.git] / meta-stx / recipes-support / eventlog / eventlog_git.bb
1 #
2 # Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 SUMMARY = "syslog replacement"
17 DESCRIPTION = " \
18         The EventLog library aims to be a replacement of the simple syslog() API \
19         provided on UNIX systems. The major difference between EventLog and syslog \
20         is that EventLog tries to add structure to messages. \
21          \
22         Where you had a simple non-structrured string in syslog() you have a \
23         combination of description and tag/value pairs. \
24          \
25         EventLog provides an interface to build, format and output an event record. \
26         The exact format and output method can be customized by the administrator \
27         via a configuration file \
28           "
29
30 LICENSE = "BSD"
31 LIC_FILES_CHKSUM = "file://COPYING;md5=b8ba8e77bcda9a53fac0fe39fe957767"
32
33 SRCREV = "a5c19163ba131f79452c6dfe4e31c2b4ce4be741"
34 PROTOCOL = "https"
35 BRANCH = "master"
36 S = "${WORKDIR}/git"
37
38 SRC_URI = "git://github.com/balabit/eventlog.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH}"
39
40 inherit autotools pkgconfig