Add initial meta-stx to support StarlingX build
[pti/rtp.git] / meta-stx / recipes-support / drbd / drbd-utils_8.4.3.bb
1 #
2 # Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 SUMMARY = "Distributed block device driver for Linux"
17
18 DESCRIPTION = " DRBD, developed by LINBIT, is a software that allows RAID 1 functionality over \
19         TCP/IP and RDMA for GNU/Linux. DRBD is a block device which is designed to build high \
20         availability clusters and software defined storage by providing a virtual shared device \
21         which keeps disks in nodes synchronised using TCP/IP or RDMA. This simulates RAID 1 but \
22         avoids the use of uncommon hardware (shared SCSI buses or Fibre Channel)."
23 HOMEPAGE = "http://www.drbd.org/"
24 SECTION = "admin"
25 LICENSE = "GPLv2+"
26 LIC_FILES_CHKSUM = "file://COPYING;md5=5574c6965ae5f583e55880e397fbb018"
27
28 # SRCREV = "89a294209144b68adb3ee85a73221f964d3ee515"
29 SRCREV = "136c0e42691aed4a4607c79969de87cb8410285c"
30 PROTOCOL = "https"
31 BRANCH = "master"
32 S = "${WORKDIR}/git"
33 PV = "8.4.3rc1"
34
35 SRC_URI = "git://github.com/LINBIT/drbd-8.4.git;name="git";protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH}"
36
37
38 # https://www.linbit.com/downloads/drbd/8.4/archive/
39
40 inherit autotools
41
42 DEPENDS += " \
43         linux-libc-headers \
44         glibc \
45         "
46 # UPSTREAM_CHECK_URI = "https://github.com/LINBIT/drbd-utils/releases"
47
48 inherit autotools-brokensep
49
50 RDEPENDS_${PN} += "bash perl-module-getopt-long perl-module-exporter perl-module-constant perl-module-overloading perl-module-exporter-heavy"
51
52 do_install_append() {
53         rm -rf ${D}/var/lock
54 }