9cda553b9ea5d447caec24af1f2ff2a3034c5810
[pti/rtp.git] / meta-stx / recipes-support / dnsmasq / dnsmasq_2.76.bb
1 SUMMARY = "Lightweight, easy to configure DNS forwarder and DHCP server"
2 DESCRIPTION = "\
3 Dnsmasq is lightweight, easy to configure DNS forwarder and DHCP server. \
4 It is designed to provide DNS and, optionally, DHCP, to a small network. \
5 It can serve the names of local machines which are not in the global \
6 DNS. The DHCP server integrates with the DNS server and allows machines \
7 with DHCP-allocated addresses to appear in the DNS with names configured \
8 either in each host or in a central configuration file. Dnsmasq supports \
9 static and dynamic DHCP leases and BOOTP for network booting of diskless \
10 machines. \
11 "
12 HOMEPAGE = "http://www.thekelleys.org.uk/dnsmasq"
13 SECTION = "net"
14
15 # GPLv3 was added in version 2.41 as license option
16 LICENSE = "GPLv2 | GPLv3"
17 LIC_FILES_CHKSUM = "\
18     file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3 \
19     file://COPYING-v3;md5=d32239bcb673463ab874e80d47fae504 \
20 "
21
22 SRC_URI = " \
23     http://www.thekelleys.org.uk/${BPN}/${BP}.tar.gz \
24     file://init \
25     file://dnsmasq-resolvconf.service \
26     file://lua.patch \
27     \
28     file://stx/dnsmasq-2.76-dns-sleep-resume.patch \
29     file://stx/dnsmasq-2.76-fix-dhcp-option-arrangements.patch \
30     file://stx/dnsmasq-2.76-pftables.patch \
31     file://stx/dnsmasq-2.76-fix-crash-dns-resume.patch \
32     file://stx/dnsmasq-2.76-warning-fixes.patch \
33     file://stx/dnsmasq-2.76-label-warning.patch \
34     file://stx/dnsmasq-2.76-label-man.patch \
35     file://stx/dnsmasq-2.76-coverity.patch \
36     file://stx/dnsmasq-2.76-dhcp-script-log.patch \
37     file://stx/dnsmasq-2.76-file_offset32.patch \
38     file://stx/dnsmasq-2.76-CVE-2017-14491.patch \
39     file://stx/dnsmasq-2.76-CVE-2017-14492.patch \
40     file://stx/dnsmasq-2.76-CVE-2017-14493.patch \
41     file://stx/dnsmasq-2.76-CVE-2017-14494.patch \
42     file://stx/dnsmasq-2.76-CVE-2017-14496.patch \
43     file://stx/dnsmasq-2.76-CVE-2017-14495.patch \
44     file://stx/dnsmasq-2.76-gita3303e196.patch \
45     file://stx/dnsmasq-2.76-underflow.patch \
46     file://stx/dnsmasq-2.76-misc-cleanups.patch \
47     file://stx/dnsmasq-2.76-CVE-2017-14491-2.patch \
48     file://stx/dnsmasq-2.76-inotify.patch \
49     file://stx/dnsmasq-update-ipv6-leases-from-config.patch \
50     file://stx/close-tftp-sockets-immediately.patch \
51     file://stx/dnsmasq.service \
52 "
53 SRC_URI[md5sum] = "6610f8233ca89b15a1bb47c788ffb84f"
54 SRC_URI[sha256sum] = "777c4762d2fee3738a0380401f2d087b47faa41db2317c60660d69ad10a76c32"
55
56 inherit pkgconfig update-rc.d systemd
57
58 INITSCRIPT_NAME = "dnsmasq"
59 INITSCRIPT_PARAMS = "defaults"
60
61 PACKAGECONFIG ?= "dbus idn"
62 PACKAGECONFIG[dbus] = ",,dbus"
63 PACKAGECONFIG[idn] = ",,libidn"
64 PACKAGECONFIG[conntrack] = ",,libnetfilter-conntrack"
65 PACKAGECONFIG[lua] = ",,lua"
66 PACKAGECONFIG[resolvconf] = ",,,resolvconf"
67
68 EXTRA_OEMAKE = "\
69     'COPTS=${@bb.utils.contains('PACKAGECONFIG', 'dbus', '-DHAVE_DBUS', '', d)} \
70            ${@bb.utils.contains('PACKAGECONFIG', 'idn', '-DHAVE_IDN', '', d)} \
71            ${@bb.utils.contains('PACKAGECONFIG', 'conntrack', '-DHAVE_CONNTRACK', '', d)} \
72            ${@bb.utils.contains('PACKAGECONFIG', 'lua', '-DHAVE_LUASCRIPT', '', d)}' \
73     'CFLAGS=${CFLAGS}' \
74     'LDFLAGS=${LDFLAGS}' \
75 "
76
77 SRC_URI += "${@bb.utils.contains('PACKAGECONFIG', 'resolvconf', 'file://dnsmasq.resolvconf file://99_dnsmasq file://dnsmasq-resolvconf-helper', '', d)}"
78
79 do_compile_append() {
80     # build dhcp_release
81     cd ${S}/contrib/lease-tools
82     oe_runmake
83 }
84
85 do_install () {
86     oe_runmake "PREFIX=${D}${prefix}" \
87                "BINDIR=${D}${bindir}" \
88                "MANDIR=${D}${mandir}" \
89                install
90
91     install -d ${D}${sysconfdir}/
92     install -d ${D}${sysconfdir}/init.d
93     install -d ${D}${sysconfdir}/dnsmasq.d
94
95     install -m 644 ${S}/dnsmasq.conf.example ${D}${sysconfdir}/dnsmasq.conf
96     cat << EOF >> ${D}${sysconfdir}/dnsmasq.conf
97
98 # Include all files in /etc/dnsmasq.d except RPM backup files
99 conf-dir=/etc/dnsmasq.d,.rpmnew,.rpmsave,.rpmorig
100 EOF
101
102     install -m 755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/dnsmasq
103
104     install -d ${D}${systemd_system_unitdir}
105
106     if [ "${@bb.utils.filter('PACKAGECONFIG', 'resolvconf', d)}" ]; then
107         install -m 0644 ${WORKDIR}/dnsmasq-resolvconf.service ${D}${systemd_system_unitdir}/dnsmasq.service
108     else
109         install -m 0644 ${WORKDIR}/stx/dnsmasq.service ${D}${systemd_system_unitdir}/dnsmasq.service
110     fi
111
112     install -m 0755 ${S}/contrib/lease-tools/dhcp_release ${D}${bindir}
113     install -m 0755 ${S}/contrib/lease-tools/dhcp_release6 ${D}${bindir}
114     install -m 0755 ${S}/contrib/lease-tools/dhcp_lease_time ${D}${bindir}
115
116     if [ "${@bb.utils.filter('PACKAGECONFIG', 'dbus', d)}" ]; then
117         install -d ${D}${sysconfdir}/dbus-1/system.d
118         install -m 644 dbus/dnsmasq.conf ${D}${sysconfdir}/dbus-1/system.d/
119     fi
120     if [ "${@bb.utils.filter('PACKAGECONFIG', 'resolvconf', d)}" ]; then
121         install -d ${D}${sysconfdir}/resolvconf/update.d/
122         install -m 0755 ${WORKDIR}/dnsmasq.resolvconf ${D}${sysconfdir}/resolvconf/update.d/dnsmasq
123
124         install -d ${D}${sysconfdir}/default/volatiles
125         install -m 0644 ${WORKDIR}/99_dnsmasq ${D}${sysconfdir}/default/volatiles
126         install -m 0755 ${WORKDIR}/dnsmasq-resolvconf-helper ${D}${bindir}
127     fi
128 }
129
130 CONFFILES_${PN} = "${sysconfdir}/dnsmasq.conf"
131
132 RPROVIDES_${PN} += "${PN}-systemd"
133 RREPLACES_${PN} += "${PN}-systemd"
134 RCONFLICTS_${PN} += "${PN}-systemd"
135 SYSTEMD_SERVICE_${PN} = "dnsmasq.service"
136 SYSTEMD_AUTO_ENABLE_${PN} = "disable"