Add initial meta-stx to support StarlingX build
[pti/rtp.git] / meta-stx / recipes-support / deltarpm / deltarpm_git.bb
1 #
2 # Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 DESCRIPTION = "Makedeltarpm creates a deltarpm from two rpms. The deltarpm can \
17                 later be used to recreate the new rpm from either filesystem data \
18                 or the old rpm. Use the -v option to make makedeltarpm more verbose \
19                 about its work (use it twice to make it even more verbose).\
20                 "
21 LICENSE = "BSD"
22 LIC_FILES_CHKSUM = "file://LICENSE.BSD;md5=574af071cf0d60a71cb781844bbe2d76"
23
24 SRCREV = "c5e0ca7482e2cfea5e4d902ffe488e0a71ed3e67"
25 # SRCREV = "8660d976f5d2b73adf1088d67341be9c3646f2f2"
26 PROTOCOL = "https"
27 BRANCH = "master"
28 S = "${WORKDIR}/git"
29
30 SRC_URI = "git://github.com/rpm-software-management/deltarpm.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH} \
31                 file://0001-Makefile-patch-fix-build-errors.patch \
32                 "
33
34 DEPENDS += " python perl bzip2 rpm zlib python xz zstd"
35
36 do_compile_append () {
37         cd ${S}
38         oe_runmake -e DESTDIR=${D} bindir=${bindir} mandir=${mandir} python
39
40 }
41
42 do_install () {
43         cd ${S}
44         oe_runmake -e DESTDIR=${D} bindir=${bindir} mandir=${mandir} install
45 }
46
47 FILES_${PN}_append += " \
48         /usr/lib/python2.7/site-packages/deltarpm.py \
49         /usr/lib/python2.7/site-packages/_deltarpmmodule.so \
50         "