Add initial meta-stx to support StarlingX build
[pti/rtp.git] / meta-stx / recipes-security / libtomcrypt / libtomcrypt_1.18.2.bb
1 #
2 # Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 SUMMARY = "A comprehensive, portable cryptographic toolkit"
17 DESCRIPTION = " \
18   A comprehensive, modular and portable cryptographic toolkit that provides \
19   developers with a vast array of well known published block ciphers, one-way \
20   hash functions, chaining modes, pseudo-random number generators, public key \
21   cryptography and a plethora of other routines. Designed from the ground up to \
22   be very simple to use. It has a modular and standard API that allows new ciphers, \
23   hashes and PRNGs to be added or removed without change to the overall end application. \
24   It features easy to use functions and a complete user manual which has many source \
25   snippet examples. \
26 "
27 HOMEPAGE = "https://github.com/libtom/libtomcrypt"
28
29 LICENSE = "PD"
30 LIC_FILES_CHKSUM = "file://LICENSE;md5=71baacc459522324ef3e2b9e052e8180"
31
32 DEPENDS = "libtool-cross"
33
34 SRC_URI = "https://github.com/libtom/libtomcrypt/releases/download/v${PV}/crypt-${PV}.tar.xz"
35
36 SRC_URI[md5sum] = "e8d22351b7c95bef423c1cd02dcf836d"
37 SRC_URI[sha256sum] = "96ad4c3b8336050993c5bc2cf6c057484f2b0f9f763448151567fbab5e767b84"
38
39 EXTRA_OEMAKE = " \
40         LIBTOOL=${STAGING_BINDIR_CROSS}/${HOST_SYS}-libtool \
41         LIBPATH=${libdir} \
42         INCPATH=${includedir} \
43         -f makefile.shared \
44         "
45
46 do_compile() {
47         oe_runmake library
48 }
49
50 do_install() {
51         oe_runmake install DESTDIR=${D}
52 }