Add initial meta-stx to support StarlingX build
[pti/rtp.git] / meta-stx / recipes-security / krb5 / krb5_%.bbappend
1 #
2 # Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16
17 FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
18
19 SRC_URI_append = "file://soname_majversion.diff \
20                  "
21 DEPENDS += "libverto"
22
23 PACKAGES_remove = "libverto"
24
25 RDEPENDS_${PN} += "\
26         libverto \
27 "
28 RDEPENDS_krb5-admin-server += "\
29         libverto \
30 "
31 RDEPENDS_krb5-kdc += "\
32         libverto \
33 "